If anyone cares...

...the blog is now updated to Ghost v0.11.0 running on Node.js 4.6.0 on my Raspberry Pi 2.

OK, as you were.